Tuesday 12th January 2016

Brief downtime scheduled

We will be going offline briefly in the next few minutes to address the recent performance issues. We appreciate your patience!

Update 11:26 EST - We are wrapping up and starting to bring back up the system. Just a few more minutes.

Update 11:41 EST - Everything is back up and running.