Wednesday 27th January 2016

Delayed email delivery

Email delivery is experiencing a delay of up to several hours. We have identified the reason and are working to mitigate the issue. (This does not affect instances using 3rd party mailing services).

Update 28 Jan, 00:52 EST - We've taking steps to mitigate future email delivery delays. However, it will take a few more hours to work through the existing queues. We're still monitoring the situation and will do so through tomorrow. Once the backlog has cleared and we're satisfied that things are moving real-time again, we'll clear this incident.

Update 28 Jan, 11:19 EST - We are continuing to experience delays with email delivery and are working hard to mitigate. We apologize for this inconvenience. Please keep an eye on this page for status updates.

Update 28 Jan, 15:45 EST - All backlogged emails should now be delivered and future emails delivered in real-time.