Sunday 20th September 2015

Platform Upgrade

A platform upgrade is in progress, accounts are temporarily inaccessible during this period.

UPDATE 20 Sept 21:05 EDT: All data has been migrated and final testing of the system configuration is on-going before bringing the full system online.

UPDATE 20 Sept 22:30 EDT: The system is online and operational.