Friday 20th May 2016

Services down

Services are down and we are working as quick as possible to restore them.

Update Services should be restored. Our upstream service provider seem to be having issues. We'll be monitoring their status and on standby to attempt to counter any trickle down effect to us.

Update 10PM ET - Our upstream provider has resolved their issues and the system has been stable. Therefore we are resolving this incident.